1. Importing References
  2. Exporting from a Reference Manager
  3. Export from Mendeley
  4. Export from Citavi
  5. Export from Zotero (and zbib)
  6. Export from EndNote
  7. Export from SciWheel

Citing in SciFlow requires you to import references first. To do this, export them from your reference management software of choice. This article covers the process of importing references as well as exporting them from every major reference managing platform, i.e., Zotero, Mendeley, Citavi, EndNote, and SciWheel.

If you are looking for a way to implement your references without manually uploading your bibliography files, SciFlow offers to synchronize your reference library with Zotero or Mendeley, which grants direct access to the respective entries right in the editor.

Import to SciFlow

SciFlow uses the BibTeX (.bib) file format for the organization of references. This file format is widely supported and reliably carries all essential information needed to quote successfully in any citation style. Therefore the references you want to use only need to be exported as bib files and then be imported into SciFlow afterward.

To initiate the import of your bibliography files, access the Reference Library menu in the sidebar and then proceed in one of two ways:

  • Click Upload from Citavi, Endnote, BibTeX, .. or use the option Upload library file from the context menu to select the desired bib files from your hard drive.
  • Drag and drop the chosen files into the library tab. Your references will then automatically migrate into the reference library.

Updating Your References

Since SciFlow uses the BibTeX file format, every bib file carries a particular key, that identifies the reference. That means that every re-upload of the same bib file automatically updates it instead of creating an unnecessary copy. Therefore, changes made in your reference management tool can transfer into SciFlow by a simple re-upload of the new bibliography.

Export from your Reference Manager

Though the result is similar, every platform has its unique way of exporting bib files.
Mendeley, Citavi, Zotero, EndNote, SciWheel

Mendeley

You can connect your Mendeley account directly to SciFlow through your documents Reference Library.

Alternatively, you can also export bib files from Mendeley to upload your references.

  • Select one or more reference entries you wish to export from your document list.
  • Go to File and then select Export.
  • Assign a name and where to save your bibliography and choose the file type BibTeX (*.bib).
  • Export the references by hitting the Save button.

Citavi

Before you export references from Citavi the support for BibTeX files must be activated.

  • Make sure LaTeX/BibTeX support is turned on (Tools > Options > Citation)
  • In the Reference Editor on the File menu, click Export.
  • Choose which references to export, then click Next.
  • Select BibTex, then click Next.
  • Choose Save to text file, click Browse..., enter a name and location for the bibliography, and click Save.
  • Choose whether you want to save the export preset for future exports, then click Next. Citavi lets you know if the export was successful.

Zotero

You can connect your Zotero account directly to SciFlow through your documents Reference Library.

If you are looking for a way to import a bibliography created with zbib, check out this article.
Alternatively, you can also export bib files from the Zotero App to upload your references.

  • Within Zotero, select the references or collections you wish to export.
  • Right-click one of the selected entries and choose the option Export Items from the appearing context menu.
  • Choose the needed file format (BibLaTeX).
  • Save your newly created reference file in a location of your choosing.

EndNote

Integrating the Export Style

EndNote requires a specific export style that enables it to export BibTeX files.

You can find and download the needed style here. To install the style, just unzip the downloaded file and double-click the contained style, which should open it in EndNote. From there, you need to implement it into your EndNote styles via Files > Save As...

In the following dialogue, you can assign a name to the style. The Save button completes the integration.

Using the Export Style

  • Activate the style using Edit > Output Styles > Style Manager by ticking the box in front of the name you previously assigned to the export style.
  • Next, set declare your export style by either choosing the appropriate style from the drop-down menu (Bibliographic Output Style) or the list of available styles via the menu route Edit > Output Styles.

  • Then export all or a portion of chosen references by selecting them and either using the export button or the menu route Files > Export.
  • In the following window, add the ending .bib to your file name. Otherwise, SciFlow won't be able to identify the references file format correctly.

Please note that your exported file name may end in .txt. If that is the case, you will have to remove that suffix for the file to function correctly.

Tips and tricks

Adding organizations as authors

Sometimes the author is not a natural person but an organization (or the name is not a western name). In that case there the first and last name can not be distinguished. To keep names in full, add a "{ }" around the name.

"{Deutsche Dermatologische Gesellschaft e.V. (DDG)}",

Keeping the spelling for German citations.

Many citation styles require citations to be in sentence case "Mary had a little lamb" as opposed to title case "Mary Had A Little Lamb". For SciFlow to automatically recognize exceptions to this rule (e.g. for German book titles), make sure to add a language to the reference and set it to de (or en for English). The abbreviations eng or ger are recognized as well.

Getting a correct access date for websites

When adding access dates for websites, make sure that it is given in the international YYYY-MM-DD format (e.g. 2020-10-20) so it can be displayed correctly (e.g. Stand: 5. Okt 2015 in German bibliographies).

SciWheel

SciWheel allows for a quick and easy way to export references, be it a single one, a chosen set, or your whole library. Select the sources you want to export by checking the box beside them. To select all available references in your library or displayed on the current page, check the box in the header row.

Once the desired entries are selected, you can download them via the export button, which is also found in the header row.

Choose Export as... in the following context menu to reach the export interface. Make sure to select the BibTex file format before you download the bib-file.

Did this answer your question?